Support portal login
Incident Report for GridPlay Productions
Resolved
Can now log into our support portal with either a gridplay.net account (SecondLife account required) or your Discord account.
No emails or passwords are stored.
Posted Jul 16, 2022 - 10:50 CDT
Investigating
We are currently adding discord support for logins. Please refrain from logging into our support portal right now as things could become funky.
Posted Jul 16, 2022 - 10:26 CDT
This incident affected: Services (GP Support).