Support Portal work
Incident Report for GridPlay Productions
Resolved
We have finished the work and will no longer touch the front page for today.
Posted Jul 04, 2022 - 11:24 PDT
Investigating
We are currently working on the front page of the Support Portal website.
The page could look funky at times.
Posted Jul 04, 2022 - 11:17 PDT